But why did Kotlin team chose 100 downTo 1 vs 100..1?
I think that the syntax 100..1 would be bad when we try to use variables instead of literals.
If we typed
for (n in b..a)
then it wouldn't be clear what loop we wanted to use.
We may have intended to count backwards but if b turns out to be smaller than a, then our program would actually count upwards! That would be a source of bugs.